阅读149 返回首页    go 阿里云 go 技术社区[云栖]


【端午小练】HDU1701-ACMer

ACMer
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3533    Accepted Submission(s): 1627


Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 

Output
For each test case, output the minumal number of students in HDU.
 

Sample Input
1
13.00 14.10
 

Sample Output
15
 

Source
2007省赛集训队练习赛(1)
 

 

/*题意:就是给你两个double的 数据 A B 
让你求一个int 数  i  满足  i*A与i*B之间只夹一个数
也就是题目中的ACMER  而此i既是所求的student*/
AC代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int i,j,T;
    double n,m;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%lf %lf",&n,&m);
       for(i=1;;i++)
       {
            if(int(m*i*0.01)-int(n*i*0.01)==1)
    break;
       }
       printf("%d\n",i);
    }
    return 0;
}

最后更新:2017-04-03 08:26:22

  上一篇:go [推荐系统]信息过载与推荐系统
  下一篇:go JDK各版本的API下载