755
京東網上商城
HDU1028 拆分數母函數
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7643 Accepted Submission(s): 5420
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
Author
Ignatius.L
題解:運用母函數 x的n次冪前的係數就是拆分數 母函數這種應用很多 循環到130打出一個表就行了 簡單的說就是模擬
多項式的乘法
#include <iostream> #include<cstdio> #include<cstring> using namespace std; int main() { int c1[150],c2[150],n; for(int i=0; i<=130; i++) c1[i]=1,c2[i]=0; for(int i=2; i<=130; i++) { for(int j=0; j<=130; j++) for(int k=0; k+j<=130; k+=i) c2[k+j]+=c1[j]; for(int j=0; j<=130; j++) c1[j]=c2[j],c2[j]=0; } while(cin>>n) cout<<c1[n]<<endl; return 0; }
最後更新:2017-04-02 15:15:05