Same binary weight
Same binary weight
时间限制:300 ms | 内存限制:65535 KB
难度:3
- 描述
-
The binary weight of a positive integer is the number of 1's in its binary representation.for example,the decmial number 1 has a binary weight of 1,and the decimal number 1717 (which is 11010110101 in binary) has a binary weight of 7.Give a positive integer N,return the smallest integer greater than N that has the same binary weight as N.N will be between 1 and 1000000000,inclusive,the result is guaranteed to fit in a signed 32-bit interget.
- 输入
- The input has multicases and each case contains a integer N.
- 输出
- For each case,output the smallest integer greater than N that has the same binary weight as N.
- 样例输入
-
1717 4 7 12 555555
- 样例输出
-
1718 8 11 17 555557
查看代码---运行号:252990----结果:Accepted
运行时间:2012-10-07 13:53:19 | 运行人:huangyibiao
01.
#include <iostream>
02.
#include <bitset>
03.
04.
using
namespace
std;
05.
06.
int
main()
07.
{
08.
unsigned
long
n;
09.
10.
while
(cin >> n)
11.
{
12.
bitset<32> b(n);
13.
int
i, index1, index0;
14.
15.
for
(i = 0; i < b.size(); i++)
16.
{
17.
if
(b.test(i))
18.
{
19.
index1 = i;
//从最低位开始找第一个1的位置
20.
break
;
21.
}
22.
}
23.
for
(i = index1+1; i < b.size(); i++)
24.
{
25.
if
(!b.test(i))
26.
{
27.
index0 = i;
//从第一个1的位置开始找,第一个出现0的位置
28.
break
;
29.
}
30.
}
31.
b.flip(index0);
32.
b.flip(index0-1);
33.
index0 --;
34.
35.
bitset<32> bit;
36.
int
j = 31;
37.
for
(i = b.size()-1; i > index0; i--)
38.
bit[j--] = b[i];
39.
for
(i = index1-1; i >= 0; i--)
40.
bit[j--] = b[i];
41.
for
(i = index0; i >= index1; i--)
42.
{
43.
bit[j--] = b[i];
44.
}
45.
cout << bit.to_ulong() << endl;
46.
}
47.
return
0;
48.
}
最后更新:2017-04-02 15:14:56