阅读881 返回首页    go 阿里云 go 技术社区[云栖]


NYOJ282-You are my brother

You are my brother
时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述

Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.

 

 

输入
There are multiple test cases.
For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.
Proceed to the end of file.
输出
For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.
样例输入
5
1 3
2 4
3 5
4 6
5 6
6
1 3
2 4
3 5
4 6
5 7
6 7
样例输出
You are my elder
You are my brother
来源
辽宁省10年省赛

 

AC代码:

#include<stdio.h>
#include<string.h>
struct node
{
       int father;
}bin[3000];
int main()
{
    int i,j,n,m,sum1,sum2,flag1,flag2,x,y;
    while(scanf("%d",&n)!=EOF)
    {
       flag1=0;flag2=0;
       sum1=0;sum2=0;
       for(i=0;i<n;i++)
       {
          scanf("%d %d",&x,&y);
          if(flag1==0&&x==1)//第一次记录1的父辈
          {
             flag1=1;bin[1].father=y;
          }
          if(flag2==0&&x==2)//第一次记录2的父辈
          {
             flag2=1;bin[2].father=y;
          }
          if(flag1==1&&x==bin[1].father)//如果几录过1的父辈,1的父辈有祖先,那么更新1的父辈,并且辈分加1
          {
             sum1++;bin[1].father=y;
          }
          if(flag2==1&&x==bin[2].father)//如果几录过2的父辈,2的父辈有祖先,那么更新2的父辈,并且辈分加1
          {
             sum2++;bin[2].father=y;
          }
       }
       //根据1和2的辈分大小来判断两人关系
       if(sum1<sum2)
       printf("You are my younger\n");
       else if(sum1>sum2)
       printf("You are my elder\n");
       else
       printf("You are my brother\n");
    }
    return 0;
}

最后更新:2017-04-03 12:56:03

  上一篇:go Linux文件共享(四)——父进程与子进程之间的文件共享
  下一篇:go Linux文件共享(三)——dup