阅读609 返回首页    go 阿里云 go 技术社区[云栖]


【JAVA大数训练】Exponentiation

Exponentiation
Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6571    Accepted Submission(s): 1824


Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the

computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 )

and n is an integer such that 0 < n <= 25.

 

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value

will be in columns 8 and 9.

 

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed

in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

 

Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12
 

Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
 

Source
East Central North America 1988

 

import java.math.BigDecimal;
import java.util.Scanner;
public class Main {
 public static void main(String[] args) {
  Scanner input=new Scanner(System.in);
  while(input.hasNext())
  {
   BigDecimal n=input.nextBigDecimal();
   int m=input.nextInt();
            n=n.pow(m);
            String str=n.stripTrailingZeros().toPlainString();
            if(str.charAt(0)=='0') //如果开头为0,将0去掉(如0.2只输出.2)
            System.out.println(str.substring(1));
            else 
            System.out.println(str);

  }
 }
}


总结:
1.charAt(int index)方法
是一个能够用来检索特定索引下的字符的String实例的方法。
charAt()方法返回一个位于提供给它的参数索引处的字符。
s.chatAt(i)的意义就是,i为条件,就是第几个字符,i的取值范围为小于s的长度.

 

 

2.substring(参数)是java中截取字符串的一个方法有两种传参方式一种是public String substring(int beginIndex)返回一个新的字符串,

它是此字符串的一个子字符串。该子字符串从指定索引处的字符开始,直到此字符串末尾。另一种是public String substring(int

beginIndex, int endIndex)返回一个新字符串,它是此字符串的一个子字符串。该子字符串从指定的 beginIndex 处开始,直到索引

endIndex - 1 处的字符。因此,该子字符串的长度为 endIndex-beginIndex。

最后更新:2017-04-03 12:56:11

  上一篇:go Spark SQL Columnar模块源码分析
  下一篇:go Xcode5.x编译64位应用时的出错问题