阅读186 返回首页    go 阿里云 go 技术社区[云栖]


HDU4925-Apple Tree

Apple Tree
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
   I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map.  In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
   The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.   For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
   For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
2
2 2
3 3
 

Sample Output
8
32
 

 

 


//找规律,水题,但是是我第一次在多校联合赛上做出的第一道题,以此纪念
AC代码:

#include<stdio.h>
#include<string.h>
struct node
{
   int x;
   int v;
}a[110][110];
int max(int n,int m)
{
  return n>m?n:m;
}
int main()
{
   int i,j,n,m,T,sum1,sum2,Max;
   scanf("%d",&T);
   while(T--)
   {
       scanf("%d %d",&n,&m);
       sum1=0;sum2=0;
       memset(a,0,sizeof(a));
       for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         {
            if(i%2!=0)
            {
               if(j%2!=0)
               a[i][j].x=1;
               else
               {
                  a[i][j].x=2;
                  a[i][j].v=1;
               }
            }
            else
            {
               if(j%2==0)
               a[i][j].x=1;
               else
               {
                  a[i][j].x=2;
                  a[i][j].v=1;
               }
            }
         }
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         {
            if(a[i][j].x==2)
            {
               if(i-1>=1)
               {
                   a[i][j].v*=2;        
               }
               if(j-1>=1)
               {
                   a[i][j].v*=2;       
               }
               if(i+1<=n)
               {
                  a[i][j].v*=2;        
               }
               if(j+1<=m)
               {
                  a[i][j].v*=2; 
               }
            }                
         }
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         if(a[i][j].x==2) sum1+=a[i][j].v;
         
         
      memset(a,0,sizeof(a));
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         {
            if(i%2!=0)
            {
               if(j%2==0)
               a[i][j].x=1;
               else
               {
                  a[i][j].x=2;
                  a[i][j].v=1;
               }
            }
            else
            {
               if(j%2!=0)
               a[i][j].x=1;
               else
               {
                  a[i][j].x=2;
                  a[i][j].v=1;
               }
            }
         }
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         {
            if(a[i][j].x==2)
            {
               if(i-1>=1)
               {
                  a[i][j].v*=2;        
               }
               if(j-1>=1)
               {
                   a[i][j].v*=2;       
               }
               if(i+1<=n)
               {
                  a[i][j].v*=2;        
               }
               if(j+1<=m)
               {
                  a[i][j].v*=2; 
               }
            }                
         }
      for(i=1;i<=n;i++)
         for(j=1;j<=m;j++)
         if(a[i][j].x==2) sum2+=a[i][j].v;
         
      Max=max(sum1,sum2);
      printf("%d\n",Max);
                         
   }
   return 0;
}

最后更新:2017-04-03 05:39:44

  上一篇:go JSON与String互转(javascript)
  下一篇:go 8月12日阿里云服务升级公告