閱讀183 返回首頁    go 阿裏雲 go 技術社區[雲棲]


UVA之1388 - Graveyard

1388 - Graveyard


Programming contests became so popular in the year 2397 that the governor of New Earck -- the largest human-inhabited planet of the galaxy -- opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places for newcomers wisely!

Input 

The input file contains several test cases, each of them consists of a a line that contains two integer numbers: n -- the number of holographic statues initially located at the ACM, and m -- the number of statues to be added (2$ \le$n$ \le$1000, 1$ \le$m$ \le$1000) . The length of the alley along the park perimeter is exactly 10 000 feet.

Output 

For each test case, write to the output a line with a single real number -- the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.

\epsfbox{p3708.eps}

Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

Sample Input 

2 1 
2 3 
3 1 
10 10

Sample Output 

1666.6667 
1000.0 
1666.6667 
0.0

【解析】




【代碼】

/*********************************
*   日期:2013-11-25
*   作者:SJF0115
*   題號: 題目1388 - Graveyard
*   來源:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=446&page=show_problem&problem=4134
*   結果:AC
*   來源:UVA
*   總結:
**********************************/
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;


int main() {
    int i,n,m;
    while(scanf("%d %d",&n,&m) != EOF){
        double ans = 0.0;
        for(i = 1;i < n;i++){
            //計算每個需要移動的雕塑坐標
            double pos = (double)i / n * (n+m);
            //累加移動距離
            ans += fabs(pos - floor(pos+0.5))/(n+m);
        }
        printf("%.4lf\n",ans * 10000);
    }//while
    return 0;
}


最後更新:2017-04-03 14:54:25

  上一篇:go SQL Server 2005 安裝圖解(圖文詳解+全程截圖)
  下一篇:go 時間子係統3_低分辨率定時框架初始化