阅读929 返回首页    go 阿里云 go 技术社区[云栖]


1052: Dinner

1052: Dinner

Time Limit: 1 Sec  Memory Limit: 32 MB
Submit: 50  Solved: 9
[Submit][Status][Web Board]

Description

Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

Input

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

Output

For each test of the input, output all the name of tableware.

Sample Input

3 basketball fork chopsticks2 bowl letter

Sample Output

fork chopsticksbowl

HINT


The tableware only contains: bowl, knife, fork and chopsticks.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include <iostream>
#include <string>
 
using namespace std;
 
bool IsEqual(string tmp)
{
    return (tmp == "bowl" || tmp == "fork" || tmp == "chopsticks" || tmp == "knife");
}
int main()
{
    int num, k, count;
    string tmp;
 
    while (cin >> num)
    {
        k = 0;
        count = 0;
        while (count < num)
        {
            cin >> tmp;
            if (IsEqual(tmp))
            {
                if (k != 0)
                {
                    cout << " ";
                }
                cout << tmp;
                k ++;
            }
            count ++;
        }
       // if (k != 0)//如果没有匹配到任何一个,就不输出回车
        cout << endl;
    }
    return 0;
}
 
/**************************************************************
    Problem: 1052
    User: 1006440533
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1272 kb
****************************************************************/

最后更新:2017-04-02 15:14:59

  上一篇:go 1075: GCC
  下一篇:go 1053: You are my brother