閱讀643 返回首頁    go 阿裏雲 go 技術社區[雲棲]


1075: GCC

1075: GCC

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 12  Solved: 4
[Submit][Status][Web Board]

Description

The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 

Input

The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

Output

Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

Sample Input

1 10 861017

Sample Output

593846

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
 
#define MAX_LEN 110
int main()
{
    long m;
    long n = 0;
    char ch[MAX_LEN];
    int testNum, i;
 
    cin >> testNum;
    for (int test = 1; test <= testNum; test++)
    {
        scanf("%s %ld", ch, &m);
        //***************確定n的值*********************************
        for (i = 0; ch[i] != '\0'; i++)
            ;
        int len = i;
 
        //cout << "ch =" << ch << endl;
       // cout << "len = " << len << endl;
        if (len >= 7)
        {
            n = m-1;
        }
        else
        {
            int k = 1;
            n = ch[len-1]-'0';
            for (int j = len-2; j >= 0; --j)
            {
                n += long((ch[j] - '0') * pow(10.0, double(k)));
                k ++;
                if (n >= m)
                {
                    n = m-1;
                    break;
                }
            }
        }
        //***********************************************************
        //cout << "n = " << n << endl;
        long long s = 1;
        for (i = n; i >= 1; i--)
        {
           //s = (1 + i * s) % m;
           s = 1 % m + ((i % m) * (s % m)) % m;
        }
        s %= m;
        cout << s << endl;
    }
 
    return 0;
}
 
/**************************************************************
    Problem: 1075
    User: 1006440533
    Language: C++
    Result: Accepted
    Time:260 ms
    Memory:1284 kb
****************************************************************/

最後更新:2017-04-02 15:14:59

  上一篇:go 國際科學黑客馬拉鬆大賽中國奪冠
  下一篇:go 1052: Dinner