閱讀335 返回首頁    go 阿裏雲 go 技術社區[雲棲]


【最大子矩陣和】HDU1081-To The Max

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8193    Accepted Submission(s): 3981


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
 

Sample Output
15
 

Source
Greater New York 2001

 

最大子矩陣和
關於最大子矩陣和的做法探討詳細請看:https://blog.csdn.net/acmman/article/details/38580931
AC代碼:

#include <stdio.h>
#include <string.h>
#include <limits.h>
#define MAXN 200
int a[MAXN][MAXN],temp[MAXN];
int n;
int getsum()
{
   int i,sum=0,max=0;
   for(i=0;i<n;i++)
   {
      sum+=temp[i];
      if(sum>max) max=sum;
      if(sum<0) sum=0; 
   }
   return max;
}
int main()
{
    int i,j,ans,k; 
 while(scanf("%d",&n)!=EOF)
    {
       memset(a,0,sizeof(a));
    for(i=0;i<n;i++)
         for(j=0;j<n;j++)
         scanf("%d",&a[i][j]);
      ans=INT_MIN;
      for(i=0;i<n;i++)//從第i行開始 
      {
         memset(temp,0,sizeof(temp));
         for(j=i;j<n;j++)//從 i行到 n-1行都嚐試一次 
         {
            for(k=0;k<n;k++)//把 j至 k行的每一列都加起來,就是矩陣壓縮 
             temp[k]+=a[j][k]; 
             
             int pre=getsum();//計算壓縮矩陣形成的一維數組的最長連續序列 
             if(ans<pre)//更新最大值 
                ans=pre; 
         }
      } 
      printf("%d\n",ans);
 }
 return 0;
}

最後更新:2017-04-03 05:39:54

  上一篇:go 【哈夫曼編碼】HDU1053-Entropy
  下一篇:go 程序員之路:十年磨一劍