閱讀709 返回首頁    go 阿裏雲 go 技術社區[雲棲]


【北大夏令營筆記-動態規劃】poj1458-Common Subsequence

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37543 Accepted: 15016
Description


A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input


The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.


Sample Input

abcfbc         abfcab
programming    contest 

abcd           mnp


Sample Output

4
2
0
Source

Southeastern 
Europe 2003





//題意:最長公共子序列
/*
輸入兩個串s1,s2.設MaxLen[i][j]表示:
s1的左邊i個字符形成的子串,與s2左邊的j個字符形成的子串的最長公共子
序列的長度(i,j從0開始計算)。
MaxLen[i][j]就是本題的“狀態”。
*/

AC代碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAXN=1100;
char s1[MAXN];
char s2[MAXN];
int MaxLen[MAXN][MAXN];
int main()
{
    int i,j,n,m;
    while(scanf("%s %s",s1,s2)!=EOF)
    {
        n=strlen(s1);
        m=strlen(s2);
        for(i=0;i<=n;i++)
        MaxLen[i][0]=0;
        for(i=0;i<=m;i++)
        MaxLen[0][i]=0;
        for(i=1;i<=n;i++)
           for(j=1;j<=m;j++)
           {
              if(s1[i-1]==s2[j-1])
                 MaxLen[i][j]=MaxLen[i-1][j-1]+1;
              else
                 MaxLen[i][j]=max(MaxLen[i][j-1],MaxLen[i-1][j]);
           }
           printf("%d\n",MaxLen[n][m]);
    }
    return 0;
}

最後更新:2017-04-03 05:39:25

  上一篇:go 操作係統結構(一)
  下一篇:go Hadoop組件概覽