閱讀659 返回首頁    go 阿裏雲 go 技術社區[雲棲]


HDU1548-A strange lift【廣搜做法】

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11510    Accepted Submission(s): 4362


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input

5 1 5 3 3 1 2 5 0
 

Sample Output

3
 

Recommend
8600   |   We have carefully selected several similar problems for you:  1385 1242 1142 1217 2066 
 
 
 
 
 
 
 
題意:一個特別的電梯,按up可升上k[i]層,到大i+k[i]層,down則到達i-k[i]層,最高不能超過n
,最低不能小於1,給你一個起點和終點,問最少可以按幾次到達目的地。
思路:搜索,采用廣度優先搜索,被搜過的情況要計算,下次之搜之前沒到過的樓層
AC代碼:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int a[210],n,flag[210];
void BFS(int s,int t)
{
   int v;
   queue<int> q;
   q.push(s);
   flag[s]=1;
   while(!q.empty())
   {
       v=q.front();
       q.pop();
       if(v==t)
         break;
       if(v+a[v]<=n&&flag[v+a[v]]==0)//向上 
       {
          q.push(v+a[v]);
          flag[v+a[v]]=flag[v]+1;
       } 
       
       if(v-a[v]>=1&&flag[v-a[v]]==0)//向下 
       {
          q.push(v-a[v]);
          flag[v-a[v]]=flag[v]+1;
       }
   }
   if(v!=t)
     flag[t]=0;
   
}
int main()
{
    int i,j,s,t;
    while(scanf("%d %d %d",&n,&s,&t),n!=0)
    {
       for(i=1;i<=n;i++)
       {
          scanf("%d",&a[i]);
       }
       memset(flag,0,sizeof(flag));
       BFS(s,t);
       printf("%d\n",flag[t]-1);
    }
    return 0;
}

最後更新:2017-04-03 05:39:42

  上一篇:go 定製scrollView來處理自動顯示與隱藏鍵盤
  下一篇:go NSString擴展