閱讀798 返回首頁    go 技術社區[雲棲]


(0! + 1! + 2! + 3! + 4! + ... + n!)%m

Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various 
programming languages. But it doesn’t contains the math operator “!”. In mathematics the symbol represents the factorial 
operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is
 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not 
multiplied by anything.) We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 
Input

The first line consists of an integer T, indicating the number of test cases. Each test on a single consists of two integer n and m.
Output

Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m. Constrains 0 < T <= 20 0 <= n < 10^100 (without leading zero) 0 < m < 1000000
Sample Input
1 10 861017
Sample Output
593846
解題思路:我采用的是化簡法:
0! + 1! + 2! + 3! + 4! + ... + n!
=1 + 1 * (1+2*~2+2*~3+....+2*~n)
=1 + 1 * (1+2 * (1 + 3*~3+....+3*~n))
=1 + 1 * (1+2 * (1+ 3 * (......(1 + n * (1 + 0)))))
這樣化簡後,可以從後往前遞推記s初始為1;然後
for (int i = n; i >= 1; i--)
 { s = 1 % m + ((i %m) * (s%m))%m ; }
s %=m;
方法一:
我的代碼如下:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

#define MAX_LEN 110
int main()
{
    long m;
    long n = 0;
    char ch[MAX_LEN];
    int testNum, i;

    cin >> testNum;
    for (int test = 1; test <= testNum; test++)
    {
        scanf("%s %ld", ch, &m);
        //***************確定n的值*********************************
        for (i = 0; ch[i] != '\0'; i++)
            ;
        int len = i;

        //cout << "ch =" << ch << endl;
       // cout << "len = " << len << endl;
        if (len >= 7)
        {
            n = m-1;
        }
        else
        {
            int k = 1;
            n = ch[len-1]-'0';
            for (int j = len-2; j >= 0; --j)
            {
                n += long((ch[j] - '0') * pow(10.0, double(k)));
                k ++;
                if (n >= m)
                {
                    n = m-1;
                    break;
                }
            }
        }
        //***********************************************************
        //cout << "n = " << n << endl;
        long long s = 1;
        for (i = n; i >= 1; i--)
        {
           //s = (1 + i * s) % m;
           s = 1 % m + ((i % m) * (s % m)) % m;
        }
        s %= m;
        cout << s << endl;
    }

    return 0;
}

方法二:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

#define MAX_LEN 110
int main()
{
    long m;
    long n = 0;
    char ch[MAX_LEN];
    int testNum, i;

    cin >> testNum;
    for (int test = 1; test <= testNum; test++)
    {
        scanf("%s %ld", ch, &m);
        //***************確定n的值*********************************
        for (i = 0; ch[i] != '\0'; i++)
            ;
        int len = i;

        //cout << "ch =" << ch << endl;
       // cout << "len = " << len << endl;
        if (len >= 7)
        {
            n = m-1;
        }
        else
        {
            int k = 1;
            n = ch[len-1]-'0';
            for (int j = len-2; j >= 0; --j)
            {
                n += long((ch[j] - '0') * pow(10.0, double(k)));
                k ++;
                if (n >= m)
                {
                    n = m-1;
                    break;
                }
            }
        }
        //***********************************************************
        //cout << "n = " << n << endl;
        long long s = 1;//0!=1
        long long t = 1;//0!=1
        long sum = 1;
        for (i = 1; i <= n; i++)
        {
            t = (t % m) * (i % m);
            s = t % m;
            sum = (s  + sum % m) % m;
        }
        cout << sum % m << endl;
    }

    return 0;
}

 

最後更新:2017-04-02 15:14:50

  上一篇:go Oracle查詢所有序列
  下一篇:go 微軟成功收購NVIDIA|微軟的野望