阅读673 返回首页    go 阿里云 go 技术社区[云栖]


【JAVA大数训练】N!

N!
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50539    Accepted Submission(s): 14212


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

 

Input
One N in one line, process to the end of file.

 

Output
For each N, output N! in one line.

 

Sample Input
1
2
3
 

Sample Output
1
2
6
 

Author
JGShining(极光炫影)
 

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
 public static void main(String[] args) {
  Scanner input=new Scanner(System.in);
  while(input.hasNext())
  {
   int n=input.nextInt();
   BigInteger m=BigInteger.ONE;
   for (int i=1;i<=n;i++) {
    m=m.multiply(BigInteger.valueOf((long)i));
   }
            System.out.println(m);
  }
 }
}

//int型数字i转换成BigInteger方法:BigInteger.valueOf((long)i)

最后更新:2017-04-03 12:56:11

  上一篇:go 深入浅出DDoS攻击防御——防御篇
  下一篇:go Sql查询原理与Select执行顺序(详细)