閱讀673 返回首頁    go 阿裏雲 go 技術社區[雲棲]


【JAVA大數訓練】N!

N!
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50539    Accepted Submission(s): 14212


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

 

Input
One N in one line, process to the end of file.

 

Output
For each N, output N! in one line.

 

Sample Input
1
2
3
 

Sample Output
1
2
6
 

Author
JGShining(極光炫影)
 

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
 public static void main(String[] args) {
  Scanner input=new Scanner(System.in);
  while(input.hasNext())
  {
   int n=input.nextInt();
   BigInteger m=BigInteger.ONE;
   for (int i=1;i<=n;i++) {
    m=m.multiply(BigInteger.valueOf((long)i));
   }
            System.out.println(m);
  }
 }
}

//int型數字i轉換成BigInteger方法:BigInteger.valueOf((long)i)

最後更新:2017-04-03 12:56:11

  上一篇:go 深入淺出DDoS攻擊防禦——防禦篇
  下一篇:go Sql查詢原理與Select執行順序(詳細)