閱讀262 返回首頁    go 阿裏雲 go 技術社區[雲棲]


UVA之1330 - City Game

【題目】

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees, factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems � he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units. The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N. The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input 

The first line of the input file contains an integer K � determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units, separated by a blank space. The symbols used are:
R � reserved unit
F � free unit
In the end of each area description there is a separating line.

Output 

For each data set in the input file print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input 

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output 

45
0

【分析】

最容易想到的算法便是:枚舉左上角坐標和長、寬,然後判斷這個矩形是否全為空地。這樣做需要枚舉O(m2n2)個矩形,判斷需要O(mn)時間,總時間複雜度為O(m3n3),實在是太高了。本題雖然是矩形,但仍然可以用掃描法:從上到下掃描。

我們把每個格子向上延伸的連續空格看成一條懸線,並且用up(i,j)left(i,j)right(i,j)表示格子(i,j)的懸線長度以及該懸線向左、向右運動的“運動極限”,如圖1-30所示。列3的懸線長度為3,向左向右各能運動一列,因此左右的運動極限分別為列2和列4


這樣,每個格子(i,j)對應著一個以第i行為下邊界、高度為up(i,j),左右邊界分別為left(i,j)right(i,j)的矩形。不難發現,所有這些矩形中麵積最大的就是題目所求(想一想,為什麼)。這樣,我們隻需思考如何快速計算出上述3種信息即可。

當第i行第j列不是空格時,3個數組的值均為0,否則up(i,j)=up(i-1,j)+1。那麼,leftright呢?深入思考後,可以發現:

left(i,j) = max{left(i-1,j), lo+1}

其中lo是第i行中,第j列左邊的最近障礙格的列編號。如果從左到右計算left(i,j),則很容易維護loright也可以同理計算,但需要從右往左計算,因為要維護第j列右邊最近的障礙格的列編號ro。為了節約空間,下麵的程序用up[j]left[j]right[j]來保存當前掃描行上的信息。


【代碼】

/*********************************
*   日期:2014-5-19
*   作者:SJF0115
*   題號: 1330 - City Game
*   地址:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=4076
*   來源:UVA
*   結果:Accepted
**********************************/
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

#define N 1001

int matrix[N][N];
int Up[N][N],Left[N][N],Right[N][N];

int main(){
    int T,m,n,i,j;
    //freopen("C:\\Users\\wt\\Desktop\\acm.txt","r",stdin);
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&m,&n);
        //輸入
        for(i = 0;i < m;i++){
            for(j = 0;j < n;j++){
                char c = getchar();
                while(c!='R' && c!='F'){
                    c=getchar();
                }
                matrix[i][j]= (c == 'F' ? 0:1);
            }//for
        }//for
        int ans = 0;
        for(i = 0;i < m;i++){
            //從左到右掃描,維護Left
            //障礙列號
            int lcol = -1,rcol = n;
            for(j = 0;j < n;j++){
                //障礙
                if(matrix[i][j] == 1){
                    Up[i][j] = Left[i][j] = 0;
                    lcol = j;
                }
                else{
                    if(i == 0){
                       Up[i][j] = 1;
                       Left[i][j] = lcol + 1;
                    }
                    else{
                        Up[i][j] = Up[i-1][j] + 1;
                        Left[i][j] = max(Left[i-1][j],lcol + 1);
                    }//if
                }//if
            }//for
            //從右到左掃描,維護Right並更新答案
            for(j = n-1;j >= 0;j--){
                //障礙
                if(matrix[i][j] == 1){
                    Right[i][j] = n;
                    rcol = j;
                }
                else{
                    if(i == 0){
                       Right[i][j] = rcol - 1;
                    }
                    else{
                        Right[i][j] = min(Right[i-1][j],rcol - 1);
                    }//if
                    //更新最大矩陣麵積
                    ans = max(ans,Up[i][j]*(Right[i][j] - Left[i][j] + 1));
                    //cout<<"ans:"<<ans<<" Up:"<<Up[i][j]<<" Right:"<<Right[i][j]<<" Left:"<<Left[i][j]<<endl;
                }//if
            }//for
        }
        cout<<ans*3<<endl;
    }//while
    return 0;
}




最後更新:2017-04-03 08:26:11

  上一篇:go C++ 鍐呰仈inline-鍗氬-浜戞爾紺懼尯-闃塊噷浜?
  下一篇:go 動態規劃-迷宮-百度之星-Labyrinth