閱讀295 返回首頁    go 阿裏雲 go 技術社區[雲棲]


poj2528-Mayor's posters

Mayor's posters

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 41092

 

Accepted: 11949

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

 

Sample Input

1

5

1 4

2 6

8 10

3 4

7 10

Sample Output

4

Source

Alberta Collegiate Programming Contest 2003.10.18

 

 

 

 

思路:離散化+線段樹

AC代碼:

#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
int n;
struct CPost
{
   int L,R;    
};
CPost posters[10100];//用來存放海報的兩個端點的結構體數組;
int x[20200];//海報的端點瓷磚編號
int hash[10000010];//hash[i]表示瓷磚i所處的離散化後的區間編號
struct CNode
{
   int L,R;
   bool bCovered;//區間[L,R]是否已經被完全覆蓋
   CNode *pLeft,*pRight; 
};
CNode Tree[1000000];//存放海報區間的線段樹
int nNodeCount=0;//結構體指針下標 
int Mid(CNode *pRoot)
{
   return (pRoot->L+pRoot->R)/2;
} 
void BuildTree(CNode *pRoot,int L,int R)
{
   pRoot->L=L;
   pRoot->R=R;
   pRoot->bCovered=false;
   if(L==R)
     return;
   nNodeCount++;
   pRoot->pLeft=Tree+nNodeCount;
   nNodeCount++;
   pRoot->pRight=Tree+nNodeCount;
   BuildTree(pRoot->pLeft,L,(L+R)/2);
   BuildTree(pRoot->pRight,(L+R)/2+1,R); 
}
bool Post(CNode *pRoot,int L,int R)
{/*插入一張正好覆蓋區間[L,R]的海報,返回ture說明區間[L,R],是部分
或全部可見的 */
   if(pRoot->bCovered) return false;//如果該部分已經被完全覆蓋,返回false 
   /*如果該部分沒有被完全覆蓋,則完全覆蓋此部分 ,並返回ture說明 插入的海報是部分
或全部可見的*/
   if(pRoot->L==L&&pRoot->R==R){
        pRoot->bCovered=true;
        return true;                         
   }
   //沒有找到海報區間要繼續尋找 
   bool bResult;
   if(R<=Mid(pRoot))
        bResult=Post(pRoot->pLeft,L,R);
   else if(L>=Mid(pRoot)+1)
        bResult=Post(pRoot->pRight,L,R);
   else{
        bool b1=Post(pRoot->pLeft,L,Mid(pRoot));
        bool b2=Post(pRoot->pRight,Mid(pRoot)+1,R);
        bResult=b1||b2; //隻要有true的,最終都是true 
   }
   //要更新根節點的覆蓋情況
   if(pRoot->pLeft->bCovered&&pRoot->pRight->bCovered) 
         pRoot->bCovered=true;
   return bResult;
   
}
int main()
{
    int i,j,k,t;
    scanf("%d",&t);
    int nCaseNo=0;
    while(t--)
    {
       nCaseNo++;
       scanf("%d",&n);
       int nCount=0;
       for(i=0;i<n;i++)
       {
          scanf("%d%d",&posters[i].L,&posters[i].R);
          x[nCount++]=posters[i].L;
          x[nCount++]=posters[i].R;
       }
       sort(x,x+nCount);
       nCount=unique(x,x+nCount)-x;//去掉重複元素
       //下麵離散化
       int nIntervalNo=0;
       for(i=0;i<nCount;i++)
       {
          hash[x[i]]=nIntervalNo;
          if(i<nCount-1)
          {
             if(x[i+1]-x[i]==1)
                nIntervalNo++;
             else
                nIntervalNo+=2;
          }                   
       } 
       
       BuildTree(Tree,0,nIntervalNo);
       int nSum=0;
       for(i=n-1;i>=0;i--)
       {
          if(Post(Tree,hash[posters[i].L],hash[posters[i].R]))
          nSum++;
       } 
       printf("%d\n",nSum);
    }
    return 0;
}

最後更新:2017-04-03 05:39:33

  上一篇:go Android 適配器教程(二)
  下一篇:go C語言內存泄露檢測--Memwatch